Forum » Last.fm Client Support

Linux & Mac Betas

 
    • muesli sa...
    • Alumni
    • 21 jul 2006, 12:12

    Linux & Mac Betas

    The latest Linux and Mac Betas can be found here:

    Linux: http://static.last.fm/client/Linux/LastFM_Linux_1.0.0b.tar.bz2
    Mac: http://static.last.fm/client/Mac/LastFM_Mac_1.0.0.1b.dmg

    Cheers and Thanks for testing,
    muesli

    • termcap sa...
    • Användare
    • 21 jul 2006, 15:00
    Hi,

    It dies as soon as I try to play anything.

    Running Slackware 10.2 w/ 2.6.13 generic kernel. Old player works fine using oss or alsa.

    I havn't received an answer on this but I hope this client is finally going to make it onto FreeBSD.

    If these comments are supposed to go on some other Beta forum, let me know.

    • thefab67 sa...
    • Användare
    • 21 jul 2006, 15:48

    the GUI works but segfaults when playing something

    Hi,

    First, I'm really happy to get some news about the new linux client.

    I'm running Fedora Core 5. Old client was working nice.

    The (really nice) GUI works but the client segfaults when I click on the play button.

    No error message in the console when it segfaults but when starting I have this :

    ./bin_LastFM: /usr/lib/libpng12.so.0: no version information available (required by ./libQtGui.so.4)

    On my system :
    lrwxrwxrwx 1 root root 19 mar 25 11:05 /usr/lib/libpng12.so.0 -> libpng12.so.0.1.2.8

    In "playback.log", I have this :

    060721 15:44:37 - 3086468816 - L1
    Initialising RtAudio failed. RtAudio error type: 7 Message: RtApi: unable to open specified device(s) with given stream parameters:
    RtApiAlsa: error setting sample rate (44100) on device (hw:AudioPCI,0): Argument invalide.


    Ideas ?

    Regards

    • muesli sa...
    • Alumni
    • 21 jul 2006, 18:07
    send me your *.log files to chris at last.fm please.

    thanks,
    muesli

  • What environment are you using to build the Mac version?

    • muesli sa...
    • Alumni
    • 21 jul 2006, 18:54
    os x tiger. gcc4. any specific things you wanna know?

    cheers,
    muesli

    • arisu sa...
    • Användare
    • 21 jul 2006, 19:04
    Is last.fm Player now closed source? If yes I really would like to now the reason for that..

    Greetings,
    Jasi

    • RJ sa...
    • Alumni
    • 21 jul 2006, 19:10
    arisu said:
    Is last.fm Player now closed source? If yes I really would like to now the reason for that..

    Greetings,
    Jasi

    Public SVN is svn://svn.audioscrobbler.net/ new Last.fm player is in there


    Linux version works nicely on kubuntu dapper here.

    Information wants to be beer.
    • muesli sa...
    • Alumni
    • 21 jul 2006, 19:26
    it's in svn://svn.audioscrobbler.net/LastFM_client/trunk

    cheers,
    muesli

    • ProN00b sa...
    • Användare
    • 21 jul 2006, 20:28

    lol

    well, to be open source you hide away your source pretty good... no notice of svn on the mainpage ! i don't think trying to hide it is the correct behaviour

    • muesli sa...
    • Alumni
    • 21 jul 2006, 21:33
    on the mainpage, i see ;-)

    it's available via svn, what more could you ask for? for 99,9% of our "normal" users the sourcecode is totally irrelevant. nothing that would justify a spot on the "mainpage". anyone who's interested can easily find it, though. just search for source or svn / click on one of the dozen links in the forums / look at the README.

    cheers,
    muesli

  • Installation on Ubuntu 6.06 LTS

    Hi,

    Have been trying to compile on Ubuntu all day. The old player is intermittent and often hangs - no idea why but it seems a common problem - so I wanted to try the beta.

    Installed qt via Ubuntu package manager, but the 'README' file says to issue 'qmake' and then 'make' to install.

    qmake needs some sort of further option to work. In other words should it be something like "qmake -project". I ran that with some success (in other words, something happened) and then ran "make" which ran with errors.

    Any ideas? A bit more detailed installation instructions would be worthwhile for the semi-competent Linux user like me who usually avoids compiling.

    Any chance of a deb file any time soon?

    • [Raderad användare] sa...
    • Användare
    • 22 jul 2006, 00:17
    are there any plans to add growl support to the mac client?

    • ProN00b sa...
    • Användare
    • 22 jul 2006, 01:43
    why not add it yourself ? i mean the client is open source ...
    and, people, at least sticky something regarding svn or source or something, i could only find the svn by using forum search (and even then i didn't know where the beta releases were on it and where the work in progress was)

  • I think a link to the svn should be included in the download page, just like it was for the old last.fm client. Because that will be the first page people will go to download the source code.

    • db3 sa...
    • Användare
    • 22 jul 2006, 16:04
    i'm getting the same error as 'thefab67' on Ubuntu 6.0.6 LTS. I don't see the segfault, but i have the same error in the playback.log when trying play something. other than that, the binary seems to run well - no graphical glitches.

    full text from playback.log:
    ************************************* STARTUP ********************************************

    060722 15:54:24 - 3073849792 - L1
    OS: Unix/Linux

    060722 15:54:24 - 3073849792 - L3
    Initialising RTAudio Playback

    060722 15:54:24 - 3073849792 - L3
    Card ID 0 - translated to internal ID 3

    060722 15:54:24 - 3073849792 - L3
    Using format RTAUDIO_SINT16

    060722 15:54:24 - 3073849792 - L1
    Initialising RtAudio failed. RtAudio error type: 7 Message: RtApi: unable to open specified device(s) with given stream parameters:
    RtApiAlsa: error setting sample rate (44100) on device (hw:nForce2,2): Invalid argument.

  • Can't compile from svn

    I tried to compile from svn (rev. 2113) and got this error:

    g++ -c -m64 -pipe -O2 -march=athlon64 -pipe -Wall -W -D_REENTRANT -DQT_NO_DEBUG -DQT_XML_LIB -DQT_GUI_LIB -DQT_NETWORK_LIB -DQT_CORE_LIB -DQT_SHARED -I/usr/share/qt4/mkspecs/linux-g++-64 -I. -I/usr/include/qt4/QtCore -I/usr/include/qt4/QtNetwork -I/usr/include/qt4/QtGui -I/usr/include/qt4/QtXml -I/usr/include/qt4 -I. -Ilib -IlibLastFMTools -Ibuild -Ibuild -o build/wizardselectupdatespage.o wizardselectupdatespage.cpp
    wizardselectupdatespage.cpp: In member function ‘void WizardSelectUpdatesPage::Populate(std::vector<CComponentInfo*, std::allocator<CComponentInfo*> >&)’:
    wizardselectupdatespage.cpp:89: error: cast from ‘CComponentInfo*’ to ‘unsigned int’ loses precision
    make[1]: *** [build/wizardselectupdatespage.o] Error 1


    Using gcc 4.1.1 and qt 4.1.4.

  • hey all:

    get this error when trying to launch the Linux client:

    $ ./bin_LastFM
    bin_LastFM: error while loading shared libraries: libLastFMTools.so.1: cannot open shared object file: No such file or directory

    I ran the binary from the directory I extracted it to. The required libraries are there. Any ideas?

    • db3 sa...
    • Användare
    • 22 jul 2006, 19:56
    GreenDayze,

    try

    $ ./lastfm

  • 10.4.7

    hey, trying to get 1.0.0.1b to work on 10.4.7(powerpc), everytime i open the app it gets as far as putting up the screen for me to enter my username/pass and then it quits itself.

    any ideas?

    Heaven Seventies - rock that pop
    http://www.last.fm/music/The+Heaven+Seventies
  • OS X problem

    When I try to configure the last.fm client on my OS X 10.4.7 machine, it "unexpectedly closes" after 5 seconds. Anyone else experienced this?

    -db
    • [Raderad användare] sa...
    • Användare
    • 22 jul 2006, 21:14
    Gurubanks said:
    When I try to configure the last.fm client on my OS X 10.4.7 machine, it "unexpectedly closes" after 5 seconds. Anyone else experienced this?


    I'm having the same problem as reckless and gurubanks.

    Here's the intro to how it's recorded in the crash log. I don't know what any of this means, but hopefully someone else does.

    Host Name: d-jedidiah-sundwalls-powerbook-g4-15
    Date/Time: 2006-07-22 14:08:20.757 -0700
    OS Version: 10.4.7 (Build 8J135)
    Report Version: 4

    Command: LastFM
    Path: /Applications/Last.fm.app/Contents/MacOS/LastFM
    Parent: WindowServer [53]

    Version: ??? (???)

    PID: 259
    Thread: 2

    Exception: EXC_BAD_ACCESS (0x0001)
    Codes: KERN_PROTECTION_FAILURE (0x0002) at 0x00000000

    • daniel_h sa...
    • Användare
    • 23 jul 2006, 09:25
    the linux binary beta client doesn't crash on my computer
    nice work!

    • daniel_h sa...
    • Användare
    • 23 jul 2006, 09:26
    the linux binary beta client doesn't crash on my computer
    nice work!

    • Podex sa...
    • Användare
    • 23 jul 2006, 09:56
    I have the same problem and message in playback.log as thefab67 and db3.

    060723 09:47:16 - 3074107616 - L1
    ************************************* STARTUP ********************************************

    060723 09:47:16 - 3074107616 - L1
    OS: Unix/Linux

    060723 09:47:16 - 3074107616 - L3
    Initialising RTAudio Playback

    060723 09:47:16 - 3074107616 - L3
    Card ID 0 - translated to internal ID 1

    060723 09:47:16 - 3074107616 - L3
    Using format RTAUDIO_SINT16

    060723 09:47:16 - 3074107616 - L1
    Initialising RtAudio failed. RtAudio error type: 7 Message: RtApi: unable to open specified device(s) with given stream parameters:
    RtApiAlsa: error setting sample rate (44100) on device (hw:CK804,0): Invalid argument.


    Using Ubuntu 6.06 LTS

Anonyma användare kan inte skriva inlägg. Vänligen logga in eller skapa ett konto för att göra inlägg i forumen.